PHP7.4 报错:Deprecated Functionality: implode(): Passing glue string after array is deprecated.

4297人浏览 2020-09-18

PHP7.4运行项目报错:Deprecated Functionality: implode(): Passing glue string after array is deprecated.(不推荐使用的功能:implode())

原因:PHP7.4版本更新了implode()函数的使用方式,下面是官方的介绍:

解决方案:

把implode()函数的两个参数调换一下位置即可!

//原来版本
implode($parts, $glue)

//php7.4版本
implode($glue, $parts)

 

推荐文章

Mac下为php7.3编译安装Redis扩展(phpredis)教程(使用brew安装的php)
2020-09-25
使用富文本编辑器CKEditor 4 加Thinkphp6实现粘贴截图上传图片功能。
2020-09-10
Mac 使用brew切换PHP版本,比如:从 php7.4 切换到 php5.6
2021-12-27
搜索文章